• The most common cause of problems is having an outdated version, so first be sure that you have the latest version by checking our downloads page.

• Remember that Billy Frontier requires Mac OS 10.2 or later. It might run on OS 9 or 10.1, but we do not support it. We know for fact that it will cause 10.1 to lock up on occasion.

• For all tech support inquiries, please send email to


Q: Is there any way to skip the Duels?

A: Yes, just press Apple-F10 when the Duel starts to skip it.